Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

e-Sword 10.5 - Problem Opening/Accessing Topic (.topx) Files

Topic 10.5 Upgrade File Locations CTL + Right or Left Click .topx

17 replies to this topic

#1 globetrotter

globetrotter

    New to Bible Support

  • Veterans
  • Pip
  • 6 posts
  • LocationBonnie Scotland
Offline

Posted 17 November 2011 - 03:46 PM

*
POPULAR

Hi All

I'm new to this Forum. Have been using eS for a couple of years -- great piece if software -- and just upgraded to 10.5.

Problem is I can't open any Topic file either on my laptop (Win7) or my PC (XP). No .topx file options appear at the bottom of the pane. CTL+ Right/Left Click does nothing -- the pane is unresponsive and the Menu icons at the top are completely inactive.

Journal and Study panes/files are fine - as was the (personal) .topx file I was working on last night before I ended the program.

Problem started immediately after I moved the file location on my home network. I've tried ending/re-loading eS, repairing via Control Panel, uninstalling/re-installing the program, and re-booting -- but the problem remains. The new 'Reference' system works fine. It even brings up the .topx file that I had been working on and which I copied into that folder -- in case that was the problem.

I've worked in the IT industry so reasonably clued up and willing to try anything.

Anyone got any ideas?

Many thanks

John

#2 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,881 posts
  • LocationGallatin, TN
Offline

Posted 17 November 2011 - 04:20 PM

Another member had a similar problem and this was the resolution:



**QC SOLUTION**

I had moved my "topic.topx" to another folder. In fact, I had moved all of my .topx files to the "...Program Files(...)\e-Sword" folder so that I could continue to edit all of my .topx files and use the Refviewer. eS10 did not like that maneuver.

I temporarily moved my "topic.topx" back to the "...Documents\e-Sword" folder, and that solved the problem. I was then able to use the "CTRL-rightclick" feature to redirect the Topic Editor window to my directory of choice. I then moved my "topic.topx" file back to my new default directory.

This should not happen. Even if the "...Documents\e-Sword" folder has no .topx files in it (or, as in my case, if eS creates an empty 2.0kb file), eSword should still allow that menu to popup. However, I imagine that problem will exist with only a rather small sample size of the eS population.



#3 globetrotter

globetrotter

    New to Bible Support

  • Veterans
  • Pip
  • 6 posts
  • LocationBonnie Scotland
Offline

Posted 17 November 2011 - 06:47 PM

Thanks for the advice. However I've tried that suggestion without success.

Endeavouring to get back to 'square one' I deleted all instances of topic.topx I could find on my disk. On program reload, I then began getting an error message.'Error Opening Topic Notes Database'. After clicking ok eS still allowed no access to the Topic pane. I noted that eS created an empty topic.topx file in \My documents\e-sword\, but on program reload gave the same error. I then copied the topic.topx file to various other folders both local to the laptop (including \Program files\e-sword\) and on the network, but it keeps giving me the same error on program load and the same symptoms in the Topics pane.

Where is the default location for topic.topx and should eS create a new one if the file doesn't exist? Must it be in the same location as study and journal note files (I have these in separate folders for organisational reasons) -- there was no problem in 9x or earlier with this. Also I don't pile everything into the same topic.topx file -- I have separate ones which I rename for each individual study. e.g. Trinity.topx, Law and Grace.topx etc.

Some kind of 'file pointer/test' bug in the program perhaps?

#4 patchworkid

patchworkid

    Resource Builder

  • Members (T)
  • PipPipPipPipPip
  • 1,544 posts
  • LocationOld England
Offline

Posted 17 November 2011 - 07:47 PM

hi,
Please try this

1 .Back up your modules
2. Remove everything of e-Sword
3. Re-install e-Sword 10.05

Now your main files should be in C:Program Files -> e-Sword folder
Look at My Computer -> e-Sword folder you should see these modules journal, bookmarks, study notx, markup and Topics modules.

In Edit (Journal ,study, and Topics should automatically open My Documents e-Sword folder

The Reference library will open Topics and Refx files that is in C:Program Files -> e-Sword folder.

Your situation happened to some of us which we resolved it. The way i did was un-install everything of e-Sword and re-install it.

I hope that this helps you.

thanks
Patchworkid
Merismos the Scriptures with Patchworkid's Study Bible Set<p>http://www.biblesupp...tudy-bible-set/, MySword -http://www.biblesupp...tudy-bible-set/

#5 globetrotter

globetrotter

    New to Bible Support

  • Veterans
  • Pip
  • 6 posts
  • LocationBonnie Scotland
Offline

Posted 17 November 2011 - 07:53 PM

Further to the above, I logged on as another user and one who had never used eS. The program set itself up and ran normally this time, no error message. However it still remained inactive in the Topics pane. This time eS created a 2K-size file, with some SQL content (viewable in Notepad), rather than the empty (0k) file it created under my own username. I copied the newly created topic.topx file from that user's docs to the program folder and logged off.

I logged on again under my own username, fired up eS and got the same error. I ended the program and, copied the other user's topic.topx file that I have saved in prog files to my own \My Documents\e-sword. I then fired up eS. No error message this time, but still no active Topics pane. So the error message I got before was eS trying to open/read an invalid file. And it appears to create a topic.topx file in \...Documents\e-sword\ by default.

Still same problem though with accessing Topics files.

#6 patchworkid

patchworkid

    Resource Builder

  • Members (T)
  • PipPipPipPipPip
  • 1,544 posts
  • LocationOld England
Offline

Posted 17 November 2011 - 08:14 PM

hi
1-? is can you open Reference Library and view Topics and refx files?
2. The Topic section is to edit a new topics or make your own topic there fore you have to press New Topic this will create a new topic to work on and it will save in My Documents e-Sword folder.

try this click on Topic press new Topic , control right click - open c:Program files e-Sword folder and see if you can see your topics in your c drive.
Merismos the Scriptures with Patchworkid's Study Bible Set<p>http://www.biblesupp...tudy-bible-set/, MySword -http://www.biblesupp...tudy-bible-set/

#7 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,881 posts
  • LocationGallatin, TN
Offline

Posted 17 November 2011 - 11:15 PM

Further to the above, I logged on as another user and one who had never used eS. The program set itself up and ran normally this time, no error message. However it still remained inactive in the Topics pane. This time eS created a 2K-size file, with some SQL content (viewable in Notepad), rather than the empty (0k) file it created under my own username. I copied the newly created topic.topx file from that user's docs to the program folder and logged off.

I logged on again under my own username, fired up eS and got the same error. I ended the program and, copied the other user's topic.topx file that I have saved in prog files to my own \My Documents\e-sword. I then fired up eS. No error message this time, but still no active Topics pane. So the error message I got before was eS trying to open/read an invalid file. And it appears to create a topic.topx file in \...Documents\e-sword\ by default.

Still same problem though with accessing Topics files.


I think I see the problem. If topics.topx doesn't have any entries, the GUI acts strange, you can't press CTRL-Open, etc. Click the New Topic icon to the right of the drop down menu in the toolbar. Add a topic title. Everything should work properly then.

#8 DoctorDaveT

DoctorDaveT

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 384 posts
Offline

Posted 18 November 2011 - 08:01 AM

Josh,

when I originally posted the QC issue with 10.0.5, I don't think I did a good enough job explaining the frustrating problem. When I moved my topic.topx file to the "...Program..." folder, eSword did create a new 2.0kb topic.topx file: but it was empty. That's why I said that type of problem should not happen.

I still think eSword 10.0.5 has a QC issue - because of exactly what you've just described. That "ctrl-right click" option should not be unavailable simply because "topic.topx" is empty.

Dave
visit www.DoctorDaveT.com for eSword modules & more
I also have MySword Modules

 


#9 globetrotter

globetrotter

    New to Bible Support

  • Veterans
  • Pip
  • 6 posts
  • LocationBonnie Scotland
Offline

Posted 18 November 2011 - 12:47 PM

Hi again all,

Just fired up eS and tried Josh's advice. I created a new topic and all the icons came alive. I was then able to open another topic file.

Many thanks for all your help. I'm in business again for the weekend :-)

John

#10 Joyce4Christ

Joyce4Christ

    New to Bible Support

  • Veterans
  • Pip
  • 1 posts
Offline

Posted 18 November 2011 - 12:48 PM

I have the same problem, my topics not working. I hope this bug gets a fix, I have no idea how to fix it and don't want to attempt it, but I miss my topics. Thanks and Shalom!



Reply to this topic



  



Also tagged with one or more of these keywords: Topic, 10.5 Upgrade, File Locations, CTL + Right or Left Click, .topx

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs