Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

mysword now uses ...


  • Please log in to reply
22 replies to this topic

#1 exscentric

exscentric

    e-Sword Fanatic

  • Veterans
  • PipPipPipPipPip
  • 328 posts
Offline

Posted 17 June 2020 - 01:04 PM

You can use esword modules and other modules in myswords new version! :-)

#2 APsit190

APsit190

    e-Sword Tools Developer

  • Members (T)
  • PipPipPipPipPip
  • 2,129 posts
  • LocationThe Land of the Long White Cloud (AKA New Zealand)
Offline

Posted 17 June 2020 - 08:43 PM

You can use esword modules and other modules in myswords new version! :-)

In short, No!



#3 DoctorDaveT

DoctorDaveT

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 397 posts
Offline

Posted 18 June 2020 - 05:26 AM

From the official MySword website -

 

A new version of MySword for Android v.11.1 has been released. MySword 11.1's major features are  support for non-encrypted ESword, MyBible, The Word and USFM bibles and modules; and other improvements and bugfixes.

 

This is great news. Thanks, Exscentric, for bringing this to our attention.
 


Edited by DoctorDaveT, 18 June 2020 - 05:27 AM.

Dave
visit www.DoctorDaveT.com for eSword modules, software tips, & more


#4 patchworkid

patchworkid

    Resource Builder

  • Members (T)
  • PipPipPipPipPip
  • 1,549 posts
  • LocationOld England
Offline

Posted 18 June 2020 - 01:25 PM

Hi.  This is very good. I did a few test:

it does not work on older versions of android. map modules does not work. pictures in topic books does not work. I tried my bible the chapter heading colour changed. 

 

If you can post anything else ya'll find out.

Thanks


Merismos the Scriptures with Patchworkid's Study Bible Set<p>http://www.biblesupp...tudy-bible-set/, MySword -http://www.biblesupp...tudy-bible-set/

#5 Tj Higgins

Tj Higgins

    e-Sword Fanatic

  • Members
  • PipPipPipPipPip
  • 732 posts
Offline

Posted 18 June 2020 - 02:02 PM

Here is what is posted on the MySword.info page about the new release of MySword:
 

What's new in Version 11.1
  1. Support for bibles, commentaries, dictionaries and books of other Bible apps. Just place the modules (zipped or not) in mysword folder in the Internal Storage and restart MySword. The following are supported:
    1. e-Sword
      1. Bibles - e-Sword version 9 to 10 (.bblx, RTF-based) and version 11 and higher (.bbli, HTML-based). Formerly, the .bblx can be renamed to .bbl.mybible but if it contained RTF formatting then they will show up in MySword, so converting to The Word then to MySword is the only alternative. But now MySword has basic RTF interpreter. Colors are mapped to MySword standard colors.
      2. Commentaries - e-Sword version 9 to 10 (.cmtx, RTF-based) and version 11 and higher (.cmti, HTML-based).
      3. Dictionaries - e-Sword version 9 to 10 (.dctx, RTF-based) and version 11 and higher (.dcti, HTML-based).
      4. Books - e-Sword version 9 to 10 (.topx and .devx, RTF-based) and version 11 and higher (.refi and .devi, HTML-based).
    2. MyBible
      1. Bibles - .SQLite3 files with optional accompanying notes in commentary file .commentaries.SQLite3. Zip file will also do.
      2. Commentaries - .commentaries.SQLite3 files.
      3. Dictionaries - .dictionary.SQLite3 files.
    3. USFM
      • The zip file name should contain the word usfm. This zip file must contain the individual books with extension .usfm. Try to test USFM zip files from https://ebible.org/.
    4. The Word
      1. Bibles - only UTF-8 encoding is supported (.ont, .ot and .nt).
      2. Commentaries - .cmt.twm files.
      3. Dictionaries - .dct.twm files.
      4. Books - .gbk.twm and .dev.twm files.

      Only unencrypted and unzipped modules are supported (EXE files are not supported).

      For Commentaries, Dictionaries and Books, only RTF content is supported (RVF is not) and compressed modules are supported but not encrypted ones.

    e-Sword, MyBible and non-Bible The Word modules are not migrated into MySword format but instead adapted by adding SQLite views or adding some fields or table. USFM and The Word Bibles are migrated to MySword format and the original file is deleted. All modules are moved into the appropriate folders.

  2. New Text-to-speech (TTS) preference: Skip parallel abbreviation.
  3. New Deluxe Editor preference for smartphones via Menu: Split view panes. This will enable the split view which is only available in tablets for Deluxe. The Split icon is also now avaiable on the right pane and can make the right pane full-width hiding the Editor.
  4. New Deluxe Search preference for smartphones via Menu in Search Bible: Split view panes. This will enable the split view which is only available in tablets for Deluxe. Added also Split icon at the bottom right to cycle the split size similar to the Editor.
Bugs Fixed in Version 11.1
  1. Fixed the bug of Dark holographic theme drop down text hard to read in Android Q.
  2. File Manager tap on .mybible and Open as for .mybible.gz and .mybible.zip no longer worked in Nougat and higher.
  3. Search History list tap sensitivity is only for the text and not the blank right of text for initial items.
  4. Edit Cross References should not have Preferences in the menu.
  5. Non-bible content popup may have an invalid creation of Bible link in case a reference pattern is found in the HTML attribute value.
  6. Strong's links on text (Deluxe) don't work on text ending in punctuation marks followed by Strong/Morphology.


#6 RevSteve

RevSteve

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 34 posts
Offline

Posted 18 June 2020 - 06:08 PM

Looks like the new version needs certain Android operating systems: ------------------------------------------------------------------------------------------- "Please also note that the latest version of MySword (MySword 11.1 and higher) requires Lollipop (Android 5.0) or higher. If your device is ICS (Android 4.0) up to Kitkat (Android 4.4), please download the older version MySword 11.0 below. If your device is Gingerbread 2.3.1 or Honeycomb, please download the older version MySword 9.1.2 below. If you still have Eclair or Froyo, please download an even older version of MySword 7.4 below." --------------------------------------------------------------------------------------------- I will be following this thread with interest to see how the new version works with its built-in converter. Keep us in the loop as you find more out.

#7 DoctorDaveT

DoctorDaveT

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 397 posts
Offline

Posted 25 June 2020 - 06:18 PM

I've written a blog post about all of this, for those who might be so inclined to read it. You can go to this page, scroll down, and click the blog link.


Dave
visit www.DoctorDaveT.com for eSword modules, software tips, & more


#8 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,886 posts
  • LocationGallatin, TN
Offline

Posted 27 June 2020 - 10:38 PM

Hmm, this is interesting. So, we really don't need a separate MySword section anymore...?



#9 DoctorDaveT

DoctorDaveT

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 397 posts
Offline

Posted 28 June 2020 - 04:54 AM

Hey, Josh,

 

In order for MyS version 11.1 to work, the device has to have Android version 5.0 ("Lollipop") or higher. According to this wikipedia article, Lollipop was introduced in the summer of 2014. My phone is at least 24 months old (it might be 36 - I can't remember which June I bought it in), and I have version 7.0. I would guess that the majority of the users here are using 5.0 or higher.

 

In your site analytics, can you tell what version of Android software is being used?


Dave
visit www.DoctorDaveT.com for eSword modules, software tips, & more


#10 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,886 posts
  • LocationGallatin, TN
Offline

Posted 29 June 2020 - 09:45 PM

Currently, 92.3% of all Android devices in existence have at least Lolipop.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users