Jump to content

Please read the Forum Rules before posting.

Photo

ToolTip Tool NT and Format Strong's Numbers


  • Please log in to reply
3 replies to this topic

#1 CalvinApprentice

CalvinApprentice

    New to Bible Support

  • Veterans
  • Pip
  • 2 posts
  • LocationIdaho, United States
Offline

Posted 16 June 2019 - 01:14 AM

Have been a member here for awhile, and decided to give module creation a whirl. I am having difficulties with the Strong's number formatting feature of ToolTip Tool NT when trying to create a bible module with Strong's numbering. I have read the ToolTip Tool NT documentation, and am sure I am following the instructions, but the problem I'm having is that all the Strong's numbers are not being formatted by the "Format Strong's Numbers" menu command. It is "hitting and missing" i.e. some are being formatted others are not. The UTF-8 text I am using has the Strong's numbers bracketed like so [H430] and if I compile the module with the brackets it formats every Strong's tag. However, I don't like the brackets, and it is easy enough to remove them with a regex tool. I understand from the documentation that there are two modes for Strong's formatting, one where there is no space between a word and it's Strong's tag, and one where there is a space. I also understand that there are two module formats, RTF and HD/HTML. I have tried compiling this with every possible combination of Strong's format mode and module type, but the issue remains. When I remove the brackets it doesn't format every Strong's tag. I have attached a screen shot to illustrate my trouble. Any help is greatly appreciated.

 

Thanks.

Sean

 

Update: If it helps anyone to solve this issue, I have noticed a pattern in the Strong's tags the "Format Strong's Numbers" menu command is skipping over and not formatting. The word just before the Strong's tag ends with an upper or lower case a,b,c or d in every instance where formatting is skipped to the exclusion of all other letters.

Attached Files


Edited by CalvinApprentice, 16 June 2019 - 04:58 PM.

"It is better to be divided by the truth, than united in error." - Steven J. Lawson


#2 Tj Higgins

Tj Higgins

    e-Sword Fanatic

  • Members
  • PipPipPipPipPip
  • 602 posts
Online

Posted 16 June 2019 - 09:24 AM



Have been a member here for awhile, and decided to give module creation a whirl. I am having difficulties with the Strong's number formatting feature of ToolTip Tool NT when trying to create a bible module with Strong's numbering. I have read the ToolTip Tool NT documentation, and am sure I am following the instructions, but the problem I'm having is that all the Strong's numbers are not being formatted by the "Format Strong's Numbers" menu command. It is "hitting and missing" i.e. some are being formatted others are not. The UTF-8 text I am using has the Strong's numbers bracketed like so [H430] and if I compile the module with the brackets it formats every Strong's tag. However, I don't like the brackets, and it is easy enough to remove them with a regex tool. I understand from the documentation that there are two modes for Strong's formatting, one where there is no space between a word and it's Strong's tag, and one where there is a space. I also understand that there are two module formats, RTF and HD/HTML. I have tried compiling this with every possible combination of Strong's format mode and module type, but the issue remains. When I remove the brackets it doesn't format every Strong's tag. I have attached a screen shot to illustrate my trouble. Any help is greatly appreciated. Thanks.

 

Sean

 

Update: If it helps anyone to solve this issue, I have noticed a pattern in the Strong's tags the "Format Strong's Numbers" menu command is skipping over and not formatting. The word just before the Strong's tag ends with a lower case "d" in every instance where formatting is skipped. i.e. GodH430 createdH1254 aboundG4052 exhortedG3870 etc.

 

It seems that the Strong's numbers that are not formatting are not set in superscript as all of the the others are. So try fixing that first and then formatting them again 



#3 CalvinApprentice

CalvinApprentice

    New to Bible Support

  • Veterans
  • Pip
  • 2 posts
  • LocationIdaho, United States
Offline

Posted 16 June 2019 - 11:07 AM

Issue has been resolved. Switching the Format Strong's Mode in the ToolTipTool settings from 2 to 1 fixed it. Thanks to JPG for assistance.

 

Blessings all,

Sean


"It is better to be divided by the truth, than united in error." - Steven J. Lawson


#4 APsit190

APsit190

    e-Sword Tools Developer

  • Members (T)
  • PipPipPipPipPip
  • 1,974 posts
  • LocationThe Land of the Long White Cloud
Offline

Posted 16 June 2019 - 05:39 PM



Have been a member here for awhile, and decided to give module creation a whirl. I am having difficulties with the Strong's number formatting feature of ToolTip Tool NT when trying to create a bible module with Strong's numbering. I have read the ToolTip Tool NT documentation, and am sure I am following the instructions, but the problem I'm having is that all the Strong's numbers are not being formatted by the "Format Strong's Numbers" menu command. It is "hitting and missing" i.e. some are being formatted others are not. The UTF-8 text I am using has the Strong's numbers bracketed like so [H430] and if I compile the module with the brackets it formats every Strong's tag. However, I don't like the brackets, and it is easy enough to remove them with a regex tool. I understand from the documentation that there are two modes for Strong's formatting, one where there is no space between a word and it's Strong's tag, and one where there is a space. I also understand that there are two module formats, RTF and HD/HTML. I have tried compiling this with every possible combination of Strong's format mode and module type, but the issue remains. When I remove the brackets it doesn't format every Strong's tag. I have attached a screen shot to illustrate my trouble. Any help is greatly appreciated.

 

Thanks.

Sean

 

Update: If it helps anyone to solve this issue, I have noticed a pattern in the Strong's tags the "Format Strong's Numbers" menu command is skipping over and not formatting. The word just before the Strong's tag ends with an upper or lower case a,b,c or d in every instance where formatting is skipped to the exclusion of all other letters.

 

rtf code for making text as superscript {\super G123} and if you wish to have it in e.g., green the code would look like this: {cf\4\super G123} and etc.

 

\cf4 is the rtf code for Color Font Green, as where \super is for subscript.

 

For more information regarding rtf code, click here to download the Word2007RTFSpec9.pdf file.

 

Trust that you will find this helpful.

 

Blessings,

Autograph.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs