Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

Changing Bibles switches UK/US keyboard layouts


5 replies to this topic

#1 kevin.king@liegeman.org

kevin.king@liegeman.org

    New to Bible Support

  • Members
  • Pip
  • 3 posts
Offline

Posted 18 January 2019 - 12:04 PM

I've been having problems for a long time with my Windows 10 machine mysteriously starting to type @ instead of ". I soon found out it was spontaeously switching from my normal UK keyboard layout to US. But, although I suspected that it might be something to do with switching between using eSword and other apps, I couldn't pin the problem down because it doesn't always happen. But I've finally figured out what is going on.

 

If I am using KJV, then I can switch between eSword and other apps to my hearts' content with no problems. But if I am using the WEB® version I can briefly switch to view the eSword window and flip back without any problem: but if I do anything that causes a redisplay of the bible text, then eSword instantly switches to US layout.

 

This is really irritating. Presumably, the WEB® file identifies the language as US English: but I don't see why it has to assume that I've suddenly started using a US keyboard. Is there any way of preventing it from happening?



#2 APsit190

APsit190

    e-Sword Tools Developer

  • Members (T)
  • PipPipPipPipPip
  • 1,936 posts
  • LocationThe Land of the Long White Cloud
Offline

Posted 18 January 2019 - 04:59 PM

Hi Kevin,

This is an OS problem, and not so much an e-Sword problem. The issue you are describing could (potentially) happen in other similar applications, including word processors. Suggest you contact Microsoft and see if they can help you with this.

 

Let us know how things went with you in attempting to resolve this problem.

 

Blessings,

Stephen (Php 1:21).



#3 JPG

JPG

    Bug Hunter

  • Members (T)
  • PipPipPipPipPip
  • 855 posts
Offline

Posted 18 January 2019 - 06:06 PM

 

 

This is really irritating. Presumably, the WEB® file identifies the language as US English: but I don't see why it has to assume that I've suddenly started using a US keyboard. Is there any way of preventing it from happening?

 

In Windows 10 settings go to "Time & Language" -> "Language" tab, and remove the English US language.



#4 kevin.king@liegeman.org

kevin.king@liegeman.org

    New to Bible Support

  • Members
  • Pip
  • 3 posts
Offline

Posted 19 January 2019 - 03:56 AM

Thanks for the suggestions. I don't really want to entirely eliminate US English from my computer, as I not infrequently wish to check US spellings, for example. (Despite being a Brit, I wish we could agree to adopt US spellings, as they seem much simpler!)

 

I'll see what I can find out from Microsoft.

 

God bless,

Kevin



#5 JPG

JPG

    Bug Hunter

  • Members (T)
  • PipPipPipPipPip
  • 855 posts
Offline

Posted 19 January 2019 - 05:50 AM

In the settings window, go to Time and Language, then on the left select Language.

 

Below the section Language, there are the different languages shown below the "Add a Language"

Select the English (United States) and choose Options.

Add a keyboard for the US language and select a United Kingdom one.

Now you can delete the US Keyboard.

Job done.



#6 kevin.king@liegeman.org

kevin.king@liegeman.org

    New to Bible Support

  • Members
  • Pip
  • 3 posts
Offline

Posted 19 January 2019 - 09:28 AM

Thanks very much, JPG! I've been browsing the Windows support forum and came up with the same method you proposed, which I carefully documented. Then I came back here and found your additional post, summarising the same method. As I'd included a bit more detail, and a couple of other ways of finding the language settings, I'm including these for the benefit of anyone else who has been suffering from this problem...

  1. First, you need to get into the Settings/Language screen. If you've already set up certain preferences, you may be able to select 'Language Preferences' via the language selector toolbar. Otherwise, open the Settings menu, search for 'keyboard' and select 'Edit language and keyboard options.'
  2. Under 'Add a language' you will be shown a list of your available languages. Click on the language for which you want to modify the keyboard option (in my case, that was English (United States), as I wanted this to use the UK keyboard).
  3. The language will now be highlighted, along with some additional buttons. Click the 'Options' button.
  4. A new 'Language options' window will be opened. In the 'Keyboards' section you will see a list of keyboard layout options that are currently available for that language via the language selector. If the layout you want is not shown (it probably won't be), click the '+ Add a keyboard' button and select it from the list.
  5. In future, when that language is selected, the keyboard layout should now default to the first option on the keyboards list. So, unless you really want to be able to choose between alternative keyboard layouts for that language, click on any unwanted layouts and click the 'Delete' button that appears. (In my current version of Windows 10 you can't directly re-order the keyboard list entries: but you can do so by deleting and then re-adding them.)
  6. That's it! No more unwanted US/UK keyboard switching!




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs