Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

Bad Reference Error at the Beginning of Chapters


  • Please log in to reply
29 replies to this topic

#11 APsit190

APsit190

    e-Sword Tools Developer

  • Members (T)
  • PipPipPipPipPip
  • 2,023 posts
  • LocationThe Land of the Long White Cloud
Offline

Posted 10 October 2018 - 05:56 PM

Here is that promised screen recorded video of doing a screen recording

 

 

I trust that this video proves itself to be helpful to everyone relating to the problems and issues you may have with e-Sword, T4, Downloading, how to install, and etc, etc, etc, etc.

 

Like a I said before, a picture paints a thousand words, but a video paints a million+ words.

 

Blessings,

Autograph.png


#12 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,243 posts
  • LocationCalifornia
Offline

Posted 11 October 2018 - 09:13 AM

Post a sample file of what you trying to build will be the easiest way to determine what is going on.



#13 LuisVega323

LuisVega323

    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
Offline

Posted 15 October 2018 - 10:25 AM

<p>I am getting a &quot;Bad Reference&quot; pop up error when it gets to the Book of Luke. It gives me the error for every single verse</p>
<p>&nbsp;</p>
<p>I have it formatted correctly (Example:&nbsp;Luk 1:1)&nbsp;and I don't see any spaces or anything wrong.</p>

Edited by LuisVega323, 15 October 2018 - 12:12 PM.


#14 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,243 posts
  • LocationCalifornia
Offline

Posted 15 October 2018 - 11:17 AM

Again - Post a sample file of what you trying to build will be the easiest way to determine what is going on.



#15 LuisVega323

LuisVega323

    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
Offline

Posted 15 October 2018 - 03:32 PM

Here is the Bad Reference error I get on every verse of Luke.

 

 

Attached Files



#16 LuisVega323

LuisVega323

    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
Offline

Posted 15 October 2018 - 03:34 PM

This is what pops up

Attached Files



#17 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,243 posts
  • LocationCalifornia
Offline

Posted 15 October 2018 - 03:38 PM

Again - Post a sample file of what you trying to build will be the easiest way to determine what is going on. Not images - the actual file or part of the file you are trying to build your project from.



#18 LuisVega323

LuisVega323

    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
Offline

Posted 15 October 2018 - 04:07 PM

I am trying to create a spanish New Testament .bblx module.

 

I have attached the text.

Attached Files

  • Attached File  NT.rtf   2.76MB   3 downloads


#19 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,243 posts
  • LocationCalifornia
Offline

Posted 15 October 2018 - 05:12 PM

OK - 2 issues, there is a non-displaying Unicode character 0x1, in 34 different places in your files which my Bible module building code does not like and there is one place where my code does not like a space, and that is "Gal 6: 1".  This code is old, and it could easily be improved, but I'll give you an "easy" way to fix your file.  (Defining easy is not always easy).

 

Open your file you want to build your Bible module from (always keep a backup), and then open the "T4 Calculator".  Do this by pressing Ctrl+Alt+Shift+A.  Enter the following 2 commands, pressing Enter after each, you can copy and paste then press Enter on the line where the command is located:

 

      FindAndReplace 'Gal 6: 1' 'Gal 6:1'

      FindAndReplace (,AV 1) ''
 

If you do this right, you should see the following in the "Calculator" after executing the commands:

 

      FindAndReplace 'Gal 6: 1' 'Gal 6:1'

1

      FindAndReplace (,AV 1) ''

34

 

NOTE:  '' is two single quotes.  You could use "" two double quotes also. 

 

Once you have executed these, then try building your module.



#20 LuisVega323

LuisVega323

    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
Offline

Posted 15 October 2018 - 05:24 PM

I followed your instructions and got the results you said.

 

I tried creating the module and AGAIN I get "Bad Reference" error on Luke 1:1 (and every verse after that)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs