Jump to content

Please read the Forum Rules before posting.

- - - - -

e-Sword 11.10 installed into Linux

14 replies to this topic

#11 dogfish


    Liking e-Sword

  • Members
  • PipPip
  • 17 posts
  • LocationMichigan

Posted 10 April 2019 - 10:11 AM

Update: I  tried this script (running Mint 19.1) and it failed in a few places because it is out of date. One of them is the e-sword file version which obviously has to be changed to1122. Other areas have to do with repository addresses and such which have also changed. The new info is available at winehq.orq, but I don't know enough about scripting to make all the changes and make everything gel. Perhaps if someone does know how to do this and rebuild a script that works it could be posted and tried.


For now I will stick with the dual-boot win/linux setup I have :)

#12 dshimer


    New to Bible Support

  • Veterans
  • Pip
  • 4 posts

Posted 14 April 2019 - 01:16 PM

E-Sword is about the only Windows program I run that is an absolute daily essential.  That said I tend to not mess too much when I get it working correctly.  However last time I did a fresh install on an 18.04 machine I found that E-Sword 11.1 seemed to install and run with the latest Wine and no modifications.  The only thing that didn't work was scripture tool tips in the commentaries.  To me this was a huge loss so I tried the winetricks command and it was totally restored.  Is there anyone really knowledgeable  that would know if every one of those libraries would be necessary to restore the tool tips or if it was one particular library?  Doesn't really matter at this point but I am curious which library he uses to display those.

#13 davejonescue


    New to Bible Support

  • Veterans
  • Pip
  • 10 posts

Posted 15 April 2019 - 09:33 PM

Hey guys.  I am running Linux Mint 18 Sylvia.  The below script worked perfect for me.  In Mint, you can even add the Module Installer making adding modules to E-Sword a breeze.  I cant leave the script below, because the post will minimize some of the linked scrip making it error upon installing.  So I have left a link to the page where I found the script instead.  Also, if someone wanted to make a video tutorial, they can use Kazam in Linux with an external mic.  God Bless.




the link to the page I found the script on is https://ubuntuforums...d.php?t=2406061

Edited by davejonescue, 15 April 2019 - 09:36 PM.

#14 DJPeter84


    New to Bible Support

  • Veterans
  • Pip
  • 2 posts

Posted 22 August 2019 - 06:21 AM

for an updated version of e-sword on Linux see http://www.biblesupp...linux-mint-191/


#15 zmaint


    New to Bible Support

  • Members
  • Pip
  • 1 posts

Posted 02 November 2019 - 05:21 PM

I just installed the latest version 12.10 using Playonlinux without issue.   I was not able to get the built in profile to load for reasons unknown.  Just installed as an unlisted program, left it all as default settings (64bit), and it worked out of the box.   The fonts were a bit funky.   I went ahead and exited and then configured to add corefonts, tahoma, MSLS31, MSXML3, MSXML6, VBRUN6, VCRUN6, and WSH57.   Fonts look normal now, downloaded all the bibles and addons without any issue. 


I'm sure the instructions above are still good, but I would make sure to put your install in a bottle so you don't conflict with any other windows programs you are trying to run or vice versa.  I use Playonlinux for it, because it makes it easy to do and add dependencies.

Reply to this topic


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Similar Topics

Latest Blogs