Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

eSword X and Time Machine


No replies to this topic

#1 Roy

Roy

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 250 posts
Offline

Posted 30 August 2017 - 12:52 PM

*
POPULAR

Hello,

 

I ran into an issue I would like to make users of the Mac version of eSword aware of.

 

I had an issue with an update from Apple that caused my machine to no longer move past the login after entering the password (I had gotten the Spinning BeachBall of Death).

 

I thought no worries... I am using TimeMachine to back up.... I'll just restore...

 

Well, it appeared that the restore functioned properly, but when I tried running eSword-X only the default library items were there. All of  my premium resources as well as the other installed items were .... gone.

 

Ok, i found this previous post (which gave me tyhe files location) and was able to search my back up. What I discovered was that the "Application Support" folder was missing from the backup. It was not being backed up. After further digging I found that that specific folder was in the "Exclude from Backup" list.

 

I also discovered that the only way I could remove that folder from the exclude list was from the command line.

 

This has to be done from a terminal window and you have to enter an administrators password to use the utility.

 

sudo tmutil removeexclusion "/Users/YourHomeDirectory/Library/Containers/net.e-sword.e-Sword-X/Data/Library/Application Support"

 

After running the above, I had TimeMachine do a backup and now the directory and related files are being backed up. 

 

Moral of the story? Don't assume that your backup is working. Check it out by testing it.

 

1) Make sure you have your email address and product keys copied down so you can reinstall the resource. (I did thank the LORD!!!)

2) If you are using Time Machine, check to be sure this folder has not been excluded from the back up process.

to do that.....

 

open a terminal window.

 

sudo mdfind "com_apple_backup_excludeItem = 'com.apple.backupd'"

 

 

will find all excluded files/paths for Time Machine.

 

sudo tmutil isexcluded "/Users/YourHomeDirectory/Library/Containers/net.e-sword.e-Sword-X/Data/Library/Application Support"

 

will check to see if that specific path is excluded.

This is something like what you would see running the above command.

 

Roys-Mac-Pro:~ roycottingham$ sudo tmutil isexcluded "/Users/roycottingham/Library/Containers/net.e-sword.e-Sword-X/Data/Library/Application Support"

[Included]    /Users/roycottingham/Library/Containers/net.e-sword.e-Sword-X/Data/Library/Application Support

Roys-Mac-Pro:~ roycottingham$ 

 
The GREEN text is what you are looking for. [Included] is good, it will be backed up. [Excluded] is bad... it will not be backed up!

 

 

and as stated above...

 

sudo tmutil removeexclusion "/Users/YourHomeDirectory/Library/Containers/net.e-sword.e-Sword-X/Data/Library/Application Support"

 

will remove the exclusion.

 

I hope this information will help prevent someone from having the same issues I experienced.

 

Note: I have also copied my resource files from this folder to a safe place where I KNOW the Time Machine is backing them up! If for some reason the backup process reverts to skipping that folder, and I need to, I can copy the files over.

 

NOTE!!!

 

Playing in Terminal and using the sudo command can be VERY dangerous to your system. Don't do it if you are not sure of what you are doing. You can render your system un-bootable and loose data with a wrong command or a slip of the fingers. But for some things that is the only way to fix issues.

 





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs