Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

Right to Left Text reversal in Tool Tip / E-sword


  • Please log in to reply
7 replies to this topic

#1 Tim Mitch

Tim Mitch

    Liking e-Sword

  • Members
  • PipPip
  • 16 posts
  • LocationGreat Lakes Area, NSW Australia
Offline

Posted 29 March 2014 - 06:21 PM

NOTE: Through lots of trial and error, I have found fixes for all of the issues below except for the non breaking space problem.

 

The remaining issue is that when making an interlinear module with text displayed in Right to Left format, the bracketed English translation of the interlinear gets broken up on text wrap where I have non breaking spaces.  It seems that E-sword is ignoring the non breaking spaces here.  This is a problem as I have to keep the Aramaic and English pairs as one unit.  Should this be happening and is there a work around?  Sorry everyone for not posting the pictures properly before... first time here.  I have posted the pictures that apply to the remaining issue.

 

Blessings,

Tim.

 

- Fixes are at the bottom....

 

Attached File  Screen Shot 2014-03-31 at 5.44.35 PM.png   93.84K   27 downloads

Attached File  Screen Shot 2014-03-31 at 5.54.32 PM.png   556.25K   27 downloads

 

Previous post:

 

I am building a module which is an Interlinear Aramaic - English New Testament.  I have the English text displaying correctly, but when Right to Left is selected in Tool Tip, and the module is loaded in E-sword, the order of the Aramaic and English words is reversed and one word is displayed before the verse 1 entry. I am wondering why this is happening, and how I can correct it.  

 

I am using non breaking spaces between each Aramaic word and it's bracketed translation, to keep the pairs together in word wrap, but when the module is loaded into E-sword the order is reversed.  I have attached some screenshots so you can see what is going on.  I am importing a  Left to Right formatted HTML file into Tool Tip and then selecting right to left in tool tip as this avoids a problem that I had of the bracketed words being broken up on word wrap when I used a RTL formatted HTML file as the source text for the module.

 

By the way, the font that is used for the Aramaic portion is displaying in English at the moment as E-sword does not seem to support Bible files using OLBHEB.ttf text.  I found that converting to Galaxie Unicode seems to display ok, it is just really slow to convert.  If there is a way to use OLBHEB.ttf in E-sword, please advise.  Thanks for your help in advance.

 

 

 

FIXES WERE: I have been able to correct the verse being displayed before the verse reference by putting the verse references on their own lines.  

 

I have corrected the reversal of word order by keeping the text in RTL mode in word when editing parts of the file there... silly me.. I have to pass this text through four different programs..... as there is no one program that wishes to perform all needed actions.


Edited by Tim Mitch, 31 March 2014 - 01:00 AM.


#2 Toma

Toma

    e-Sword Addict

  • Veterans
  • PipPipPipPip
  • 53 posts
Offline

Posted 30 May 2014 - 07:08 PM

Tim, are you saying that simply opening the file in Word and then editing it in Tooltip was the solution to the Aramaic text being swapped backwards?



#3 Tim Mitch

Tim Mitch

    Liking e-Sword

  • Members
  • PipPip
  • 16 posts
  • LocationGreat Lakes Area, NSW Australia
Offline

Posted 15 June 2014 - 05:24 AM

Thomas, I found that it was sensitive to the format of the text as selected in word, but that didn't fix the problem completely, I still have not found a solution to having the text show up in RTL format in E-sword. For the moment I have given up on doing the module in RTL format and have shelved it due to more urgent matters.  



#4 Tim Mitch

Tim Mitch

    Liking e-Sword

  • Members
  • PipPip
  • 16 posts
  • LocationGreat Lakes Area, NSW Australia
Offline

Posted 17 June 2014 - 06:54 AM

I still haven't been able to make the non breaking spaces behave themselves, but one possibility is that I can place a character instead of the nonbreaking space and then change the text color of that character to white so it is not visible.  At this point this is the only fix that I have come up with that may work.  I will update with the success of this option.



#5 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,205 posts
  • LocationCalifornia
Offline

Posted 17 June 2014 - 10:27 AM

If you are using the Hebrew Unicode Fixup in Tooltip Tool, try the following file:

https://dl.dropboxus...TIPTOOLNT233.w3

 

This file is an unreleased update to Tooltip Tool NT v2.32 which will include non-breaking spaces in the Hebrew chain of words. 

 

To apply the update, download the above file and put it into your "Program Files (x86)\e-Sword Tooltip Tool NT" folder, and restart the program.  The try the Hebrew fixup again and let us know if that helps or not.



#6 Tim Mitch

Tim Mitch

    Liking e-Sword

  • Members
  • PipPip
  • 16 posts
  • LocationGreat Lakes Area, NSW Australia
Offline

Posted 24 June 2014 - 06:03 AM

Thanks BH. will have to give that a try and get back to you.



#7 Tim Mitch

Tim Mitch

    Liking e-Sword

  • Members
  • PipPip
  • 16 posts
  • LocationGreat Lakes Area, NSW Australia
Offline

Posted 24 June 2014 - 07:44 AM

BH. I tried it and it does work with non breaking spaces, but only if I export the bible module as a unicode version.  Unfortunately for some reason that prevents my hebrew which is in galaxie unicode from displaying in the module in e-sword.  If it do the Hebrew Unicode Fixup, it is converted to Tiberius and that also does not show up in e-sword.  Not sure why this is, it has been causing me lots of headaches.  The Hebrew text shows up only as ??????? If you have any ideas why this is please let me know.  

 

I can save the module in the standard mode and the unicode hebrew shows up fine..... but no non breaking spaces.

 

Also in standard mode the e-sword text will be in the correct RTL format, but when saved as unicode the module displays with reversed text so the text is LTR but it is on the right margin.  HELLLLPPPP!!!! LOL  I need the unicode text to display correctly, with nonbreaking spaces showing up correctly and the text showing up in RTL word order.


Edited by Tim Mitch, 24 June 2014 - 07:47 AM.


#8 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,205 posts
  • LocationCalifornia
Offline

Posted 24 June 2014 - 08:44 AM

Do NOT use the Unicode mode in T4.  The other modes are still unicode. 

 

Fonts - NOTE - it matters not what font is used in T4 as e-Sword sets the font for display.  You need to set the font in e-Sword itself. 

 

Post a sample of the work you are doing, say the first couple of chapters of one book so I can see what is happening.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs