Jump to content

Please read the Forum Rules before posting.

Photo

e-Sword ToolTip Tool NT


  • Please log in to reply
826 replies to this topic

#21 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,195 posts
  • LocationCalifornia
Offline

Posted 04 January 2012 - 10:59 AM

If it goes well - I'll be surprised? Do try the Topic Preview option. And I do appreciate any feedback.

#22 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 04 January 2012 - 11:19 AM

If it goes well - I'll be surprised? Do try the Topic Preview option. And I do appreciate any feedback.


The Preview works good, generally. There's something buggy with images. If I cut and paste an image (sometimes once, sometimes two or three times) I get a read/write clipboard error. And after a paste or two, the image pastes as an outline. When it starts that, the topic preview doesn't work anymore, obviously.

It seems the goal of Topic Preview it to show the user they can't have an image as the last item in a topi, I assume.

#23 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,195 posts
  • LocationCalifornia
Offline

Posted 04 January 2012 - 11:23 AM

The Preview works good, generally. There's something buggy with images. If I cut and paste an image (sometimes once, sometimes two or three times) I get a read/write clipboard error. And after a paste or two, the image pastes as an outline. When it starts that, the topic preview doesn't work anymore, obviously.

It seems the goal of Topic Preview it to show the user they can't have an image as the last item in a topi, I assume.

Understand that all the copy and paste functions are being handled by the underlying RTF control. I'm not "touching" the data. The preview purpose is to assess whether the image will show as you expect the image to show up in e-Sword. This is partly because I can't exactly tell. NOW - there may be something I'm missing. I can insert the image as a SINGLE "character", and then it will "I think" show up as expected, however, then text flow around the image does not work well. So, there is still much to learn.

#24 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 04 January 2012 - 11:28 AM

Understand that all the copy and paste functions are being handled by the underlying RTF control. I'm not "touching" the data. The preview purpose is to assess whether the image will show as you expect the image to show up in e-Sword. This is partly because I can't exactly tell. NOW - there may be something I'm missing. I can insert the image as a SINGLE "character", and then it will "I think" show up as expected, however, then text flow around the image does not work well. So, there is still much to learn.


Right, here's an example of an image, and the clipboard error. Maybe because the image is the last thing in the topic. It also does this if the image is not the last thing in the topic, but the clipboard error doesn't appear sometimes.

Attached File  clipboard-error.png   113.08K   10 downloads

#25 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 04 January 2012 - 11:30 AM

This is what it looks like when there's data after the image and I copy/paste the image:

Attached File  clipboard-error2.png   74.71K   4 downloads

#26 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 04 January 2012 - 11:33 AM

Ohh I see what's happening. T4's text control doesn't like Microsoft Word's clipboard monitor/tracker/collector. If I turn that off, this all goes away. :)

I should have made ya stare at the code for a while before telling you... :P

#27 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,195 posts
  • LocationCalifornia
Offline

Posted 04 January 2012 - 11:59 AM

Ah, and you see the key, the error message is coming from the Text Control itself. It would be interesting if you tried the same thing in e-Sword to see if you get the same response.

#28 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 04 January 2012 - 12:07 PM

Ah, and you see the key, the error message is coming from the Text Control itself. It would be interesting if you tried the same thing in e-Sword to see if you get the same response.


Affirmative, same error in e-Sword when the MS Word Clipboard Monitor is running.

#29 Josh Bond

Josh Bond

    Administrator

  • Administrators
  • PipPipPipPipPip
  • 2,878 posts
  • LocationGallatin, TN
Offline

Posted 05 January 2012 - 11:58 AM

Here's some quick feedback.

Tooltipping seemed to work flawlessly on a large 7 meg topic file. The progress bar got stuck midway and never updated afterwards. No big deal, though.

I generated the topic file with a few hundred topics (÷divisions) with no issues. That's good.

My one complaint is I have to tooltip twice, essentially. The first time, I click Scripture > Tooltip to generate the e-Sword compatible references. No problems there.

But how do I know all the references were valid? I now have to click Scripture > Validate References and T4 again has to run the tooltip parsing code again to find out which ones were bad. Under T3, the bad references would appear in the lower pane without "tooltipping" again. This will effectively double the tooltipping time and that won't go over well with those with slower computers.

I'd recommend storing the bad references in a temp file and populating the Validate References window with that, without running the whole process again. Or store all the references in a temp file, noting the good and bad ones. Then populate the Validate References window based on the option to show all references or just bad ones. But running that tooltip parse code again, not a great idea, in my humble opinion. :)

Edit: One nitpicky thing I DO like very much. The new RTF control supports — marks instead of converting them to -. That always bugged me in the previous version...

Edited by Josh Bond, 05 January 2012 - 12:06 PM.


#30 BH.

BH.

    Utility Developer

  • Contributors
  • PipPipPipPipPip
  • 1,195 posts
  • LocationCalifornia
Offline

Posted 05 January 2012 - 12:09 PM

Actually, the list is generated every time any text is tooltipped. All I need to do is to either open the VerseList window or give you the option to open it, or just open it if there are any bad verses found, or .... :-)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs