Jump to content

Please read the Forum Rules before posting.

Photo
- - - - -

e-Sword Version 13 does not start


  • This topic is locked This topic is locked
41 replies to this topic

#11 Son seeker

Son seeker

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 33 posts
Offline

Posted 28 March 2021 - 10:04 AM

The reason it is not working is that download is being corrupted during the download process by either MS Edge or Windows Defender. I just download the program using Google Chrome and had no issue with download. This issue is related to Windows Defender and other antivirus software and how they protect Windows. 

 

I wish that was really the problem, but unfortunately it isn't. My download was not corrupted - it passed the CRC32 check: 93FEB31F.

Regardless of what browser I use to download the installation file, e-Sword 13 will not start on my PC after a clean installation.

My only guess is that it's something similar to the problems some had with the first release of version 12.x, which required an update later to fix the issue.



#12 Son seeker

Son seeker

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 33 posts
Offline

Posted 28 March 2021 - 10:07 AM

There is another step the above users have not noticed. They must look for the e-Sword-InstallShield Wizard. This is running in the task bar. License Agreement. Rick Meyers has added the following instruction: "Please read the following license agreement carefully. e-Sword (Registered) Copyright © 2000-2021 Rick Meyers. All Rights Reserved worldwide. Notice that there are two options > I accept the terms in the license agreement. > I do not accept the terms in the license agreement.
NOTE: The default option is the second, in which you do NOT accept the terms of the license agreement. If you do NOT respond appropriately, then the InstallShield will not be allowed to proceed, and e-Sword version 13.0.0 will NOT be loaded into the PC in the required drive, path, and e-Sword folder. Rick Meyers is checking whether you can pay attention to instructions, and whether you are prepared to surrender your own will, and to comply appropriately. God uses exactly the same method.

The missing information about audio Bibles: Load e-Sword version 13.0.0 Then open the "Help" tab, and look at "About". There is a paragraph, which tells us:
"All audio Bibles are generously provided by Bible.is, a ministry of Faith Comes By Hearing. More information can be found at www.bible.is"
You will find details on Bible.is - Faith Comes by Hearing = https://www.faithcom...urces/bible-is

 

Of course I clicked on the option to accept the terms of the license agreement, otherwise e-Sword would not install at all. That is not the problem, but rather that a properly installed version 13 will not run on my PC.


Edited by Son seeker, 28 March 2021 - 10:21 AM.


#13 Katoog

Katoog

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 1,115 posts
Online

Posted 28 March 2021 - 10:33 AM

Based on "Date modified" in the e-Sword map are 2 files changed:
License.pdf and e-Sword.exe

If you have Windows 10:
right click on e-Sword.exe and click on Properties and Security.
Look to Everyone, SYSTEM, Administrators
By Permissions (look to the V mark for Allow)
Full control V
Modify V
Read & execute V
Read V
Write V
Special permissions

If the V mark is not there need you to click Edit "to change permissions".
___

The registry is also changed but I can't help with this because my computer knowledge is limited.
I hope that none of your security programs blocks changes in the registry.

 


Restored Holy Bible 13 and the Restored Textus Receptus

http://rhb.altervista.org/homepage.htm


#14 Olaf Bacon

Olaf Bacon

    e-Sword Fanatic

  • Veterans
  • PipPipPipPipPip
  • 149 posts
  • LocationSouth Africa
Online

Posted 28 March 2021 - 10:37 AM

Of course I clicked on the option to accept the terms of the license agreement, otherwise e-Sword would not install at all. That is not the problem, but rather that a properly installed version 13 will not run on my PC.

Please contact Rick Meyers, at https://e-sword.net/feedback.html if the new e-Sword was not loaded into your ...\e-Sword folder in your PC. Check again, if you change the name of the existing e-Sword.exe or move that file somewhere else, then, when you run the setup, and also respond to the parallel tasks of the e-Sword InstallShield, in the taskbar, then the new e-Sword should then be created. Maybe Rick's version does not over-write your previous e-sword.exe properly.

Edited by Olaf Bacon, 28 March 2021 - 10:53 AM.


#15 Son seeker

Son seeker

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 33 posts
Offline

Posted 28 March 2021 - 01:58 PM

Please contact Rick Meyers, at https://e-sword.net/feedback.html if the new e-Sword was not loaded into your ...\e-Sword folder in your PC. Check again, if you change the name of the existing e-Sword.exe or move that file somewhere else, then, when you run the setup, and also respond to the parallel tasks of the e-Sword InstallShield, in the taskbar, then the new e-Sword should then be created. Maybe Rick's version does not over-write your previous e-sword.exe properly.

 

I've contacted Rick and look forward to his response.

It looks like my situation is a very rare one - no else reporting similar issues. Happy for that!



#16 Nuno Miguel

Nuno Miguel

    New to Bible Support

  • Members
  • Pip
  • 7 posts
Offline

Posted 28 March 2021 - 04:52 PM

Unfortunately, same problem here, though on Windows 7 Home Premium SP1 x64. Anyway, here's what happened: downloaded the new setup file with the latest Firefox without any issues. Once it was done when launching the setup for the first time my Avast Antivirus blocked the installation process. I added an exception then I disabled all Avast shields. Tried it again and it installed the new version over the previous one, no troubles whatsoever, but when launching the program it doesn't start. I opened the task manager to check for any anomalies and noticed that when I try to launch it the "e-sword" process appears but then it disappears as if it's closed automatically (even with Avast shields disabled). Uninstalled it completely, did a clean install, same issue. Already sent a report to Rick.Meanwhile, back to installing the previous version.


Edited by Nuno Miguel, 28 March 2021 - 05:46 PM.


#17 Olaf Bacon

Olaf Bacon

    e-Sword Fanatic

  • Veterans
  • PipPipPipPipPip
  • 149 posts
  • LocationSouth Africa
Online

Posted 29 March 2021 - 12:12 AM

Suggestion. Try a "restart", which will force the PC to reinitialize the information in memory. After the 20H2 updates [applicable between October 2020 to March 2021], which were updated during end of March 2021, there were various changes in Microsoft updates, and security changes, and some settings from the Control Panel were moved to Microsoft Windows Settings; which they have repaired, and the PC needs to have Windows Update re-run. Note that, after a "restart", it is necessary to ask for Windows Update three times, sequentially, with nothing more found needing update, in order for the PC to check certain requirements.

Edited by Olaf Bacon, 29 March 2021 - 12:13 AM.


#18 Son seeker

Son seeker

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 33 posts
Offline

Posted 29 March 2021 - 12:29 AM



Suggestion. Try a "restart", which will force the PC to reinitialize the information in memory. After the 20H2 updates [applicable between October 2020 to March 2021], which were updated during end of March 2021, there were various changes in Microsoft updates, and security changes, and some settings from the Control Panel were moved to Microsoft Windows Settings; which they have repaired, and the PC needs to have Windows Update re-run. Note that, after a "restart", it is necessary to ask for Windows Update three times, sequentially, with nothing more found needing update, in order for the PC to check certain requirements.

 

That's the first thing I did when version 13 didn't run, but it made no difference.

I'm pretty sure the problem is not with the setup on my PC, but with the new version itself. The same thing happened with the initial release of version 12.x which required an update later to fix the issue.

I expect that others will report similar problems, and within time we'll have a version 13.01 to solve it.



#19 Tj Higgins

Tj Higgins

    e-Sword Fanatic

  • Members (T)
  • PipPipPipPipPip
  • 976 posts
Offline

Posted 29 March 2021 - 10:25 AM

That's the first thing I did when version 13 didn't run, but it made no difference.

I'm pretty sure the problem is not with the setup on my PC, but with the new version itself. The same thing happened with the initial release of version 12.x which required an update later to fix the issue.

I expect that others will report similar problems, and within time we'll have a version 13.01 to solve it.

These were the the updates made to all 3 versions of e-Sword 12

 

e-Sword version 12.2 
New Dim Light greenish background color which may ease eye strain for some people.
 
Bible Search improved to locate words that include accents on the first or last character.   
 
User-made Bible modules can now include footnotes in the text and database.  
 
e-Sword version 12.1 
Downloader updated to accomodate the AMG Publishers titles now being sold through eStudySource.  
 
e-Sword version 12.0 
New Low Light display setting to make viewing the text easier on your eyes.   
 
New App Themes to further customize the e-Sword interface to your liking.   
 
Hundreds of refinements throughout the app, including a rebuilt STEP Reader, improved Resource Options dialog and bulk printing/copying of Journal Notes in date ranges.

Try right clicking the program icon and selecting "Run As Administrator" 



#20 Son seeker

Son seeker

    e-Sword Supporter

  • Veterans
  • PipPipPip
  • 33 posts
Offline

Posted 29 March 2021 - 12:32 PM

Try right clicking the program icon and selecting "Run As Administrator" 

 

Made no difference.

I just installed version 13 for the 4th time and it still does not run.

Waiting for an update . . .

My suggestion: anyone installing version 13 should first back up their copy of version 12.2 just to be safe.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users




Similar Topics



Latest Blogs